环境

树莓派2b
系统:raspbian

问题

在树莓派下无法用apt-get安装任何软件,尝试update或者upgrade也会遭遇失败。提示一堆
Failed to fetch http://raspberrypi.collabora.com/...
或者
Err http://repository.wolfram.com ...
或者
Err http://archive.raspberrypi.org ...

原因

肯定是国内不能访问这些更新源。
所以按照网上的方法修改下面两个文件

  • /etc/apt/sources.list
deb http://mirrors.ustc.edu.cn/raspbian/raspbian/ stretch main contrib non-free rpi
  • /etc/apt/sources.list.d/raspi.list
deb http://mirrors.ustc.edu.cn/archive.raspberrypi.org/debian/ stretch main ui

还是不行,有一部分是从改完的源访问了,不过还是有很多不是从新的源访问导致错误。

解决

除了上面两个文件需要修改。在下面这个目录中
/etc/apt/sources.list.d
还存在collabora.list和wolfrm.list,这两个也要给他干掉,只留下我们修改过的raspi.list即可。

pi@pi2 /etc/apt/sources.list.d $ ll
total 16
-rw-r--r-- 1 root root  48 Jun 20  2014 collabora.list.bak
-rw-r--r-- 1 root root  79 Jun 28 20:28 raspi.list
-rw-r--r-- 1 root root  55 May 18  2019 raspi.list.bak
-rw-r--r-- 1 root root 120 Jan 30  2014 wolfrm.list.bak

更新

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo rpi-update

搞定。


版权属于:芒果爱吃胡萝卜

本文链接:http://mangolovecarrot.net/2020/06/28/132

转载时须注明出处及本声明

Last modification:June 28th, 2020 at 08:52 pm